Problems with battles (crashes) at Napoleon TW

Sep 22, 2012
61
11
8
25
Flanders
#1
Hi,
I'm having a problem with Napoleon TW. Every time I want to start a battle on the battle-map, the game crashes (campaign map and auto-resolving works fine), I looked it up and apparantly this is a more common issue. I'm not brilliant with pc's so if anyone could help me with wath this guy has said on this forum: http://www.twcenter.net/forums/showthread.php?t=471120 He's talking about you need to be able to see hidden files and that's point one of the list of things you need to do to fix this... So if anyone could tell me what this guy has written on there in a more human-like language or if someone knows what to do I would be really grateful.
Thanks

Jasper
 

Grelite

Well-Known Member
Sep 21, 2012
386
479
63
27
The Netherlands
#2
I’ve deduced that the problem is that Napoleon Total War doesn’t think the GPU has any VRAM so it crashes when it starts to run. To fix this you have to go to this file path: C: Users: (insert name): AppData: Roaming: The Creative Assembly: Napoleon: script (To get to this you have to be able to see hidden files and folders. Also, I used Windows 7).
Once you open the preferences.script text file, you will find a line about 10 lines down that probably looks like this:
gfx_video_memory 0; # gfx_video_memory <int>, Override available video memory (bytes) #
You will notice that the gfx_video_memory is 0. I believe that this is the problem that prevents Napoleon Total War from running with the GPU. To fix the problem, you need to change the gfx_video_memory value to whatever your GPU memory is. The line in my preferences.script file looks like this:
gfx_video_memory 2147483648; # gfx_video_memory <int>, Override available video memory (bytes) #.
So first you have to find out what your GPU memory is. Here's some basics to know which number you need:
256 MB = 268435456
512 MB = 536870912
1 GB = 1073741824
2 GB = 2147483648
4 GB = 4294967296

Then need to enable seeing hidden files. If you use Windows 7, you open up any folder, click on 'Organize' (top-left), go to 'Folder and Search options'.
A 'Folder Options' menu should appear.
Go to the 'View' tab.
It should show a list of display options for folders.
Under 'Hidden files and folders' select the 'Show hidden files, folders, and drives' option.
Now click on 'Apply to Folders' and then 'Yes' in the alert that pops up.
Now hidden folders should be visible and you can close the folder options menu.

Next you go to C:\Users\<username>\AppData\Roaming\The Creative Assembly\Napoleon\script
In this folder you will find a file named 'preferences.script', which you need to open with notepad.
Once you have opened it with notepad you find the line 'gfx_video_memory 0; # gfx_video_memory <int>, Override available video memory (bytes) #'.
You need to change the '0' to the number you had to find before, correlating to your GPU memory. Save the file and close it.

This is what the post says to do. Note that I don't know if this is the same problem you have, or if it works. I'd advise you to backup your 'preferences.script' file before changing it.

Good luck.
 
Likes: jasper.vth
Sep 22, 2012
61
11
8
25
Flanders
#3
So first you have to find out what your GPU memory is. Here's some basics to know which number you need:
256 MB = 268435456
512 MB = 536870912
1 GB = 1073741824
2 GB = 2147483648
4 GB = 4294967296

Then need to enable seeing hidden files. If you use Windows 7, you open up any folder, click on 'Organize' (top-left), go to 'Folder and Search options'.
A 'Folder Options' menu should appear.
Go to the 'View' tab.
It should show a list of display options for folders.
Under 'Hidden files and folders' select the 'Show hidden files, folders, and drives' option.
Now click on 'Apply to Folders' and then 'Yes' in the alert that pops up.
Now hidden folders should be visible and you can close the folder options menu.

Next you go to C:\Users\<username>\AppData\Roaming\The Creative Assembly\Napoleon\script
In this folder you will find a file named 'preferences.script', which you need to open with notepad.
Once you have opened it with notepad you find the line 'gfx_video_memory 0; # gfx_video_memory <int>, Override available video memory (bytes) #'.
You need to change the '0' to the number you had to find before, correlating to your GPU memory. Save the file and close it.

This is what the post says to do. Note that I don't know if this is the same problem you have, or if it works. I'd advise you to backup your 'preferences.script' file before changing it.

Good luck.
Thank you for replying, I will try this out as soon as I have the time (probably within the next few hours)
 
Sep 22, 2012
61
11
8
25
Flanders
#4
So first you have to find out what your GPU memory is. Here's some basics to know which number you need:
256 MB = 268435456
512 MB = 536870912
1 GB = 1073741824
2 GB = 2147483648
4 GB = 4294967296

Then need to enable seeing hidden files. If you use Windows 7, you open up any folder, click on 'Organize' (top-left), go to 'Folder and Search options'.
A 'Folder Options' menu should appear.
Go to the 'View' tab.
It should show a list of display options for folders.
Under 'Hidden files and folders' select the 'Show hidden files, folders, and drives' option.
Now click on 'Apply to Folders' and then 'Yes' in the alert that pops up.
Now hidden folders should be visible and you can close the folder options menu.

Next you go to C:\Users\<username>\AppData\Roaming\The Creative Assembly\Napoleon\script
In this folder you will find a file named 'preferences.script', which you need to open with notepad.
Once you have opened it with notepad you find the line 'gfx_video_memory 0; # gfx_video_memory <int>, Override available video memory (bytes) #'.
You need to change the '0' to the number you had to find before, correlating to your GPU memory. Save the file and close it.

This is what the post says to do. Note that I don't know if this is the same problem you have, or if it works. I'd advise you to backup your 'preferences.script' file before changing it.

Good luck.
It didn't work. But thanks for helping me anyway.
I saved it but as soon as I start a battle it crashes again and the video-memory changes back to zero... Don't know how to fix this.
But thanks anyway ;-) it was really appreciated
En ik zie nu juist dat je uit Nederland komt, dat had het communiceren misschien nog wat makkelijker gemaakt :D
 

Grelite

Well-Known Member
Sep 21, 2012
386
479
63
27
The Netherlands
#5
It didn't work. But thanks for helping me anyway.
I saved it but as soon as I start a battle it crashes again and the video-memory changes back to zero... Don't know how to fix this.
But thanks anyway ;-) it was really appreciated
En ik zie nu juist dat je uit Nederland komt, dat had het communiceren misschien nog wat makkelijker gemaakt :D
A shame it didn't work.

But yeah, I'm Dutch. I'd seen you were from Flanders, but I won't speak Dutch on these forums outside of PMs as not to exclude people.
 
Sep 22, 2012
61
11
8
25
Flanders
#7
Just a question, so I tried what Grelite said and changed the zero to the correct number. But I have noticed that there are standing some other zero's, like texture, unit, water, terrain qualities. These also all stand at zero, could this have something to do with the issue? Thanks
 

Grelite

Well-Known Member
Sep 21, 2012
386
479
63
27
The Netherlands
#8
There's no use trying to change these haphazardly and the chances of those having to do with the problem are slim. You will have to find the reason it crashes first. If you can't find out there's a few things you can check:

-Have you updated your drivers?
-If it's on Steam you can verify the integrity of the local cache, see if that brings up errors.
-If all else fails, try reinstalling the game.
 
Sep 22, 2012
61
11
8
25
Flanders
#9
There's no use trying to change these haphazardly and the chances of those having to do with the problem are slim. You will have to find the reason it crashes first. If you can't find out there's a few things you can check:

-Have you updated your drivers?
-If it's on Steam you can verify the integrity of the local cache, see if that brings up errors.
-If all else fails, try reinstalling the game.
Reinstalling is on top of my list if something fails. Tried that 4 or 5 times already.
Drivers should be allright, my laptop isn't even a year old. And I don't get what you're saying with the middle one (like I said, I'm a real noob at pc stuff, I'm just like: put the disk in, install, press play :p )
And thanks for the help :D
 

Grelite

Well-Known Member
Sep 21, 2012
386
479
63
27
The Netherlands
#10
Reinstalling is on top of my list if something fails. Tried that 4 or 5 times already.
Drivers should be allright, my laptop isn't even a year old. And I don't get what you're saying with the middle one (like I said, I'm a real noob at pc stuff, I'm just like: put the disk in, install, press play :p )
And thanks for the help :D
Ah, so you don't have it on Steam. Then never mind the middle one. Other than checking if your drivers, there's nothing I can think of.

Or maybe you didn't get the right GPU number? Just to make sure: it's the memory of your graphics card, not your RAM.
 

Grelite

Well-Known Member
Sep 21, 2012
386
479
63
27
The Netherlands
#12
If you right-click the game on your games list on Steam and select 'Properties', there's a button under 'Local Files' tab that says 'Verify integrity of game cache...'. This will check on some files to see if it's been properly installed or remained uncorrupted. I doubt it will return an error, but it's worth a try.
 
Sep 22, 2012
61
11
8
25
Flanders
#13
If you right-click the game on your games list on Steam and select 'Properties', there's a button under 'Local Files' tab that says 'Verify integrity of game cache...'. This will check on some files to see if it's been properly installed or remained uncorrupted. I doubt it will return an error, but it's worth a try.
Thanks man, I will try it. Still learning ;-) Appreciate the help and the patience :D
 
Sep 22, 2012
61
11
8
25
Flanders
#14
If you right-click the game on your games list on Steam and select 'Properties', there's a button under 'Local Files' tab that says 'Verify integrity of game cache...'. This will check on some files to see if it's been properly installed or remained uncorrupted. I doubt it will return an error, but it's worth a try.
Didn't work, I also trew the problem on the steam-forum for Napoleon TW. I really was suprised to see so many people with the same issue. I started to think when I first expirienced this problem (because it has worked just fine for quite some time) and I came to the conclusion that a lot of people started to have this issue after napoleon TW downloaded an upgrade to fix some issue's (you know, the thing that steam does automatically to fix some bugs and stuff). So I don't think I can do much about it. Looked it up, a lot of people already went to the creative assembly to ask if they could look into this problem. But they aren't going to do anything. So I will just have to play the other games of the TW- series then. Just wanted to give you the full story.
And I wanted to thank you (of course ;) ) yet again for all the help, appreciate it :D
 
Sep 22, 2012
61
11
8
25
Flanders
#16
Just wanted to inform you. My laptop crashed completely and I lost everything (I had a made a back- up though so not really a big issue) But after that I made work about downloading and installing all the free updates for my NVidia. And I also applied the fix which we had discussed here, and now it works fine again :)